[Zope] zope fstcgi lose connection

Maric MICHAUD maric at aristote.info
Sun May 16 12:35:12 EDT 2004

I use zope with apache/fastcgi under debian, the trouble I have is that 
if no request is done to a zope instance page for a long period, I get 
an internal error with the apache log :
(111)Connection refused: FastCGI: failed to connect to server 
"/var/www/myzope": connect() failed
  I tried it in socket and port mode for the same result, I also tried 
to play with appConnTimeout option but it failed.
Any idea ?

apache 1.3.29 zope 2.6.4 libapache-mod-fastcgi 2.2.10

Apache conf :
<IfModule mod_fastcgi.c>
         FastCgiIpcDir /var/run/zope
         FastCgiExternalServer /var/www/myzope -host localhost:9673 
-pass-header Authorization -appConnTimeout 0
         #FastCgiExternalServer /var/www/myzope -socket default.soc 
-pass-header Authorization -appConnTimeout 0
         <Location /myzope>
                 SetHandler fastcgi-script

Zserver conf (done with zopectl configuration files) :
/usr/bin/python2.2 /usr/lib/zope/z2.py -L fr_FR -F 9673 -W 9674 -m 9675 
-l /var/log/zope/default/Z2.log --pid /var/run/zope/default/Z2.pid -p 
/var/lib/zope/cgi-bin/default -u zope -M 
/var/log/zope/default/Z2-detailed.log -z /usr/lib/zope 

More information about the Zope mailing list