[Zope] How can a folder vanish?

Rupert Redington rupert at neontribe.co.uk
Thu May 20 05:20:33 EDT 2004

On Tuesday night at around 5.30 BST a folder (of type 'Plone Folder') 
vanished from within a plone instance on my zope server. None of the 
users with sufficient privilege to do this will own up... Nothing 
unusual so far, right?

Looking through the access logs I can see successful requests for the 
folder and its contents up to a certain point, then a couple of minutes 
later we start serving errors instead.

The aspect of this which is spooking me is that I can find no reference 
to any relevant folder deletion - or indeed any activity in that area of 
the site at all - in the undo information (btw - is there any way of 
searching undo records other than by hand through the tabs in the ZMI?)

The folder seems to have simply vanished.

I'd be very grateful for any suggestions about how such a thing might 
happen - or how I might discover more about the sequence of events.



PS: For your Information:

	We are running:

Zope Version  (Zope 2.6.1 (binary release, python 2.1, linux2-x86), 
python 2.1.3, linux2)

Python Version 2.1.3 (#1, Sep 19 2002, 13:15:46) [GCC egcs-2.91.66 
19990314/Linux (egcs-1.1.2 release)]

CMF 1.3.1

Plone 1.0.3

And a host of products - details available if anyone thinks it might help.

The zope server restarts cleanly without any unfamiliar errors :-)

I have tried removing/regenerating the Data.fs.index
I have tried packing the database (on a backup copy of the Data.fs) - (I 
  read somewhere this might help with a POSkey error?)
I am attempting to examine the Data.fs with fsrecover.py and fstest.py 
but they are new to me so I'm treading gently...

More information about the Zope mailing list