[Zope] ExternalEditor problem

Des Dougan des at DouganConsulting.com
Mon May 31 01:51:15 EDT 2004

On Sun, 2004-05-30 at 00:39, Des Dougan wrote:
> I'm setting up Plone 2, and have been trying to configure the
> ExternalEditor helper application on my SuSE 9 desktop. When I click on
> an edit link, a temporary file is created on the PC, but the helper app
> does not open the editor. However, when I run zopeedit.py on the command
> line, I get a "FATAL ERROR: 'url'" message, and the file I entered as
> the parameter is deleted. I've tried with several different file types,
> and with my own ID and the root user, and see the same result each time.
> The traceback file created has the word "None" in it - nothing else.

I corrected this problem by defining an editor in my .zope-external-edit
file. I've subsequently tried to edit files locally. While the files
I've tried (the custom CSS file, and logo.jpg) have opened successfully
in the associated local editor, I get an error from Zope ("Could not
save to Zope. Error occurred during HTTP put: 405 Method not allowed")
when I try to save, and in the event log I see:

raise MethodNotAllowed, 'Method not supported for this resource.'
MethodNotAllowed: Method not supported for this resource.

I've searched the archives, but can find nothing that would indicate
where I'm going wrong. What am I missing?



Des Dougan, Principal
Dougan Consulting Group

Ph: 604-980-2848       Email: des at DouganConsulting dot com     


Design - Implementation - Support

More information about the Zope mailing list