[Zope] Installing DCOracle2 in AIX 5.1

Debojit Hazarika debojit.hazarika at db.com
Thu Nov 18 07:06:20 EST 2004


I am trying to install DCOracle2 (DCOracle2-1.2.tar) in an AIX 5.1 box.

I have tried various options but it does not seem to work.

When i try to *make*  i get the below error

        (cd src;  ./testora python)
-n Checking ORACLE_HOME...
-n Checking for Oracle version...
/u01/app/oracle/product/9.2.0/lib/libclntsh.so not readable; unable to
determine your oracle version.
make: 1254-004 The error code from the last command is 2.


Later i tried to follow the instructions in the below link to install it.


But this time i got a different error message as mentioned below

>python setup.py install
Traceback (most recent call last):
  File "setup.py", line 36, in ?
    raise exceptions.RuntimeError,'Python must be linked against -lpthread'
RuntimeError: Python must be linked against -lpthread

Can someone please provide me some suggestion to make this right and get
DCOracle2 installed for Oracle 9i.

Many thanks in advance,



Diese E-Mail enthält vertrauliche und/oder rechtlich geschützte Informationen. Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich erhalten haben, informieren Sie bitte sofort den Absender und vernichten Sie diese Mail. Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail ist nicht gestattet.

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.

More information about the Zope mailing list