[Zope] Re: Zope or Python blocking on select()

Tres Seaver tseaver at zope.com
Tue Feb 8 08:12:40 EST 2005

Hash: SHA1

David Swift wrote:

| Running Zwiki 0.36 on Zope 2.7.4-0 on Python 2.4, glibc-2.3.4-3, kernel
| 2.4.22-nptl (fedora core 1).

Python 2.3.4 is the recommended, supported version of Python.

| Whenever we hit a ZWiki page, there is a delay of 8 seconds before the
| first page is sent.  Subsequent objects for that request are sent in
| reasonable (i.e. sub-second) times.  Every individual page request seems
| to cause this delay.  I have tried all 3 ways of setting the
| LD_ASSUME_KERNEL variable, tried recompiling Python using the
| '--with-lib=' option for the different thread libraries, tried Python
| 2.3.3, and all this still gives the same result - a nasty 8 seconds delay.

It looks as though your delay is in communicating with a ZEO server --
the speedup after first load would be explained by the presence of the
object in the ZEO client cache.

| Has anyone else run into a delay like this?  Is anyone using a similar
| kernel/Python/Zope combination successfully?

I run Zope 2.7.4 with ZEO (on the same machine) on FC1 without seeing
such issues, using a Python built for the purpose (I don't reuse
/usr/bin/python).  I don't see such issues there.

- --
Tres Seaver                                tseaver at zope.com
Zope Corporation      "Zope Dealers"       http://www.zope.com
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


More information about the Zope mailing list