[Zope] Using ZEO for remote access

Etienne Labuschagne elabuschagne at gmail.com
Sun Feb 20 14:28:41 EST 2005

On Sun, 20 Feb 2005 19:05:31 +0100, Dieter Maurer <dieter at handshake.de> wrote:
> Etienne Labuschagne wrote at 2005-2-19 21:03 +0200:
> > ... ZEO client connecting to ZEO server ...
> >I have tried all the permutations of clients on Windows and Linux
> >connecting to a ZEO running on Windows and Linux, here are the
> >results:
> >
> >Windows -> Linux ZEO : Hangs
> >Windows -> Windows ZEO : Hangs
> >Linux->Linux ZEO : Works
> >Linux->Windows ZEO : Works.
> >
> >It seems my problem is with clients running on Windows.  Funny thing
> >is, the Zope instance I have on Windows can connect fine.  So it
> >should be do-able from Windows.
> It is. Colleagues of mine connect from Windows ZEO clients
> to a Unix ZEO server.
> And your Zope (as you noticed), too, is a ZEO client.
> Are you sure that you use the correct host and port?
> --
> Dieter

I have solved my problem.  

I only get the lock-ups with the Python installed on my machine.  Not
when using the Python interpreter supplied with the Zope.  After
stepping through with the debugger, I realised that I have a ZEO and
ZODB in my site-packages of my Python installation.  The ZEO in my
Python installation is 2.1.5c1.  The ZEO supplied with my Zope is

I guess there is some incompatability with the two.  What threw me off
course, was that I put the correct ZEO on the sys.path and assumed
that was the one that was used.  In reality, an older one "earlier" in
the path was used.

Sorry for the trouble, I could have solved my own problem if I took
the trouble of firing up the debugger earlier!


More information about the Zope mailing list