[Zope] major problems placing authentication on an extranet site-security flaw?

Chris Withers chris at simplistix.co.uk
Wed Feb 8 18:09:31 EST 2006

michael nt milne wrote:
> I have major problems here trying to set-up authentication over a whole
> Plone site using Zope. Using my superuser account I've navigated to the site
> root page in the ZMI where it lists all the site pages and objects etc. I've
> then gone into security, scrolled down to the bottom and for the 'View'
> option I have tried all combinations of 'Manager', 'Authenticated' and
> 'Aquire'. It simply won't work.

You're simply doing it wrong then ;-)

> I get a pop-up box but the superuser manager pass doesn't work.

What does it say when you hit cancel? have you tried enabling verbose 
security in zope.conf?

> I find the Zope security, permissions set-up hideously complex and unusable
> to be honest and it doesn't even seem to work.

Then for gods sake stop trying to use Zope and go find some toy system 
you do understand!

> Very frustrated.

So are we, quit bugging us until you've learned a bit more about how 
things work, started with something simple, or just plain raised your IQ 
a little ;-)


Simplistix - Content Management, Zope & Python Consulting
            - http://www.simplistix.co.uk

More information about the Zope mailing list