[Zope] Re: Zope scheduling problem

Pawel Lewicki lewicki at provider.pl
Fri Feb 17 04:14:52 EST 2006

Nicholas Watmough napisał(a):
> Hello,
> I'm not sure if this is the correct forum for my question.
> I'm running Zope 2.9.0 (though I've tried it on 2.8.5, with the same 
> problem).
> I have a Python script in a Zope folder that checks a specified email 
> address, packages all the emails and attachments, and adds them into a 
> PloneArticle running on a Plone site. It finds the correct PloneArticle 
> to add the item into, by doing a ZCatalog search (on the Plone 
> portal_catalog). This works properly when I run the script myself. The 
> user I run this as has the Manager role.
> I've set a proxy for the script so it runs as a Manager.
> However, when I set a ZopeScheduler to run this script, I get an error 
> where the ZCatalog doesn't find any results when I search for the 
> PloneArticle instance. Now the article I am searching for is catalogued, 
> so I'm not sure why this is happening.
> This may be a problem with ZopeScheduler, or with Plone's catalog. Not 
> sure  which.
> Any assistance would be appreciated.
> Nick

The problem is with portal_catalog. See/apply this patch


More information about the Zope mailing list