[Zope] Zope scheduling problem

Nicholas Watmough nickw at deakin.edu.au
Fri Feb 24 01:38:15 EST 2006

Thanks for that. It worked perfectly.

Out of interest, why am I unable to access the method from with my Zope 
python code? What is a private object, and why is it private?



Martijn Pieters wrote:
> On 2/19/06, Nicholas Watmough <nickw at deakin.edu.au> wrote:
>> I tried using unrestrictedSearchResults and got a security permission
>> error, saying I didn't have permission to access
>> unrestrictedSearchResults().
>> When I turned on verbose security, I got the following error:
>> Unauthorized: The object is marked as private. Access to
>> 'unrestrictedSearchResults' of (CatalogTool at
>> /DCARF/project_file_system/portal_catalog) denied.
>> How do I change the permissions so I can access this method?
> You can't, but you can access the method from unrestricted code.
> Unrestricted code is any python code not stored in a Python Script or
> a Pagetemplate object. An External Method or a code part of a Zope
> Product would do the trick.
> --
> Martijn Pieters

More information about the Zope mailing list