[Zope] product security changes from 2.8 to 2.8.5 ?

Ed Colmar ed at greengraphics.net
Mon Feb 27 19:11:43 EST 2006

Hey Andreas, thanks for the reply.

I have Globals.InitializeClass(classname) at the end of my product code 
(outside the class)
I turned on Verbose Security, but hmm...  maybe this is not a security 
issue after all.

I have code that worked within my product before like:

 def send_password_reminder(self, email):
     """  blah """

Now I see get a name error when trying to access it.

*Error Type: NameError*
*Error Value: name 'send_password_reminder' is not defined

I thought it was a security problem...  Is this related to something else?

Thanks again!


*Andreas Jung wrote:

> --On 27. Februar 2006 15:20:11 -0800 Ed Colmar <ed at greengraphics.net> 
> wrote:
>> Hello
>> I recently moved my zope product developed on a 2.8 server on to a 2.8.5
>> server, and all of my python code is no longer being published out.
>> In the past I had been using a doc string  """ doc """ to make methods
>> accessible.  I realize this is not the proper procedure, but it worked.
>> Now, on the 2.8.5 server, all of these are refused.
>> I've been going through and doing 
>> security.declarePublic('methodname') on
>> everything I want to be public, but it does not appear to have any 
>> effect.
>> Are there any other changes that I need to make to my product in 
>> order to
>> get back the functionality I had previously?
> Do you call InitializeClass()?
> Perhaps VerboseSecurity might help you.
> -aj

More information about the Zope mailing list