[Zope] Newbie install from source

zope at redpumas.com zope at redpumas.com
Fri Mar 17 05:13:20 EST 2006


I'm installing Plone from source onto a RedHat EL4 test server using
as my reference.

I have got as far as "Setting up the software"
but this is the part I'm having difficulty understanding

"Extract the Plone tarball. This will give you a folder called Plone-2.1
(presuming you have version 2.1), in which you will see a number of
products folders, such as CMFPlone and CMFCore. Copy all these product
folders (not the top-level Plone- folder) into

The Plone-2.1.2/CMFPlone/install.txt lists these as mandatory



  - Zope 2.7.8 (or 2.8.5)

  - CMF 1.5.5 (not 1.4)
     Included in the Plone tarball

  - CMFQuickInstallerTool 1.5.5 or newer
  - GroupUserFolder 3.5 or newer
  - BTreeFolder2 1.0.2 or newer
  - CMFFormController 1.0.6 or newer
  - SecureMailHost 1.0.1 or newer
  - Archetypes 1.3.6 or newer
  - ATContentTypes 1.0.2 or newer
  - ATReferenceBrowserWidget 1.1 or newer
  - ResourceRegistries 1.1 or newer
  - ExtendedPathIndex 2.2 or newer
  - CMFDynamicViewFTI 1.0.1 or newer

  - Python Imaging Library 1.1.5 or newer
     Not included in the Plone tarball
     Note: You have to build PIL with jpeg and png support. See the README
     of PIL for more information.

  - Placeless Translation Service 1.2.5 or newer
  - PloneTranslations 2.1.2
  - PloneLanguageTool 0.9 or newer

as neither CMF 1.5.5 or Python Imaging Library 1.1.5 are included in the
Plone-2.1.2 tar ball I am wondering; which is correct the "install.txt" or
is it the "how-to/setup-from-source"?



More information about the Zope mailing list