[Zope] invalid load key

William Heymann kosh at aesaeion.com
Mon Oct 30 23:21:22 EST 2006

On Monday 30 October 2006 20:47, William Heymann wrote:
I know it is bad form to reply to your own post but I managed to fix it so I 
wanted to say how in case anyone else runs into this problem.

> This is the traceback I am getting when I try to pack the db
> Traceback (innermost last):
>   Module ZPublisher.Publish, line 115, in publish
>   Module ZPublisher.mapply, line 88, in mapply
>   Module ZPublisher.Publish, line 41, in call_object
>   Module App.ApplicationManager, line 426, in manage_pack
>   Module ZODB.DB, line 605, in pack
>   Module ZODB.FileStorage.FileStorage, line 1348, in pack
>   Module ZODB.FileStorage.fspack, line 482, in pack
>   Module ZODB.FileStorage.fspack, line 228, in findReachable
>   Module ZODB.FileStorage.fspack, line 304, in findReachableAtPacktime
>   Module ZODB.FileStorage.fspack, line 377, in findrefs
>   Module ZODB.serialize, line 625, in referencesf
> UnpicklingError: invalid load key, '^\'

For some reason the object that was damage was inside a ZCatalog. Darned if I 
know why that key would refer to something in a ZCatalog. 

How I found it was I just tried to export one folder after another and worked 
my way down until I found that object as the one that would not export. Once 
I had it found I deleted it and just created another one and it works now.

So if anyone else runs into this problem and can't find the object if you do 
an export it will throw an error if it has the bad object in it so you can 
just export containing folders until you get the problem and then go down 
until you find the appropriate object.

More information about the Zope mailing list