[Zope] Re: i18n/L10n support in zope2

harshad behere hbehere at zeomega.com
Thu Apr 10 08:23:06 EDT 2008

Maurits van Rees wrote:
> harshad behere, on 2008-04-10:
>> Maurits,
>> Thanks for the reply and suggestions.
>> I tried i18n:translate="", it works fine.
>> But if I change domain (e.g i18n:domain="mydomain") it doesn't work. Is 
>> domain attribute is related to the domain specified in .po file, coz the 
>> example .po file which comes with PlacelessTranslationService has domain 
>> as 'PlacelessTranslationService' and if I used same it works fine.
> Yes, the two should be the same.  But if you use this domain and other
> people use it too because it is the standard example then you can get
> conflicting translations.
Yes completely agreed.

I tried changing domain in given example .po file (e.g. to 
"Domain=mydomain\n"), but it doesn't work even after doing "Reload
catalog" for corresponding .po file object using PTS ZMI. I found reload 
catalog works if we modify message ids/text. Any idea how PTS manages 
this headers (like Domain/Content-Type etc) ? Is it possible to 
reload/refresh/rebuild this information ?

Thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope/attachments/20080410/7fcaa6ad/attachment.htm

More information about the Zope mailing list