[Zope] Upgrade to 2.7.2 results in all content unavailable - SOLUTION!

Thomas Bennett bennetttm at appstate.edu
Mon Apr 14 17:10:05 EDT 2008

So was this RHEL machine customized to update ZOPE with YUM or Up2date or is 
this a default.  I have been using Fedora and CentOS (both built from redhat 
dist.) for some time now and haven't seen this issue.  This would be nice to 
know seeing that I am currently moving all my linux servers to RHEL5.



On Monday 14 April 2008 14:25, Wes Modes wrote:
> Thanks everyone for the help.  It was a combination of useful
> suggestions, blind optimism, tenacious persistence, and fervent desire
> to keep my job that eventually solved the problem.
> It was neither super simple, not really complex.  The list of things I
> tried spans 6 pages in my notebook, so I won't bore you with that.  But
> I will give you a quickie summary.
> The Problem:  A previous sysadmin had built both zope and python from
> source.  As is often the case, things end up in non-standard locations
> (or the standard locations change over time).  So with the monthly
> system software updates, the installer (Red Hat EL 4's up2date program,
> based on yum) gave me new versions of zope and python.  I apparently
> went from Zope 2.7.2 to Zope 2.10.5 and from Python 2.3.X to Python
> 2.5.2.  I had no intention of updating either package, but neither was
> in the up2date exceptions file.
> After the update, zope was still running but wasn't serving any
> content.  Even the ZMI and the Congratulations page were unavailable.  I
> could see that the data storage had not been lost, but nor had it been
> touched since the update.  I tried all sorts of things to get everything
> working again, but it looked like my best bet would be to install the
> latest versions of Zoep and Python and then import the old data.  So
> that's the path I took.
> The Solution:  I rebuilt both zope and python to the most current stable
> versions.  In attempting to make the new packages work together, I noted
> that the old versions of python were installed in /usr/lib and the new
> versions were installed in /usr/local/lib.  So even when I went back to
> a 2.4.X version of python it couldn't find all of the modules that had
> been earlier built for it.  Once I moved some of the needed modules
> over, and rebuilt others, zope at least started working normally.
> Then after I moved the old data into place and restarted zope, all of
> the content returned.
> Summary:  Be careful when updating python, it may leave all of its
> modules behind.
> Wes

Thomas McMillan Grant Bennett		Appalachian State University
Operations & Systems Analyst		P O Box 32026
University Library			Boone, North Carolina 28608
(828) 262 6587

"... using OpenOffice.org, and save them back to disk automatically,
in MS Word format.  They surf the Web, check e-mail, do instant 
messsaging, view YouTube videos, visit their Facebook pages, learn 
touch-typing skills and lots more.  Our public library has been 
offering these Linux public stations for the past three years."
 - Phil Shapiro Linux Journal January 2008

Library Systems Help Desk: https://www.library.appstate.edu/help/

More information about the Zope mailing list