[Zope] Re: disappearing external methods

Garry Saddington garry at schoolteachers.co.uk
Wed May 7 16:05:03 EDT 2008

On Wednesday 07 May 2008 18:13, Josef Meile wrote:
> Garry Saddington schrieb:
> >> Have you tried deleting the .pyc files associated with the external
> >> methods and then restarting zope?
> >
> > There are no .pyc files in any of our installations.
> > Have you used the Zope that comes with Centos or from Zope.org?
> Tried, as somebody say, to open the external method on the ZMI, then
> press save, and test if it works. If you have a lot of them, you could
> try Dieter's advice here:
> http://mail.zope.org/pipermail/zope/2002-July/119101.html
> Check also that you move all .py files from your external methods and
> that file and folder permissions allow the user running zope to access
> them.
> I'm not sure but I think this problems with the external methods only
> happen with old zope versions. Which version you have?

I am re-compiling on Centos to see if that helps


More information about the Zope mailing list