[Zope] psycopg import error

Thomas Bennett bennetttm at appstate.edu
Tue Jun 23 16:41:40 EDT 2009

Have you installed psycopg2 2.0.11, not the adapter but the library for 
python?  and is it in the python path for your Zope python?

I'm thinking you have psycopg not psycopg2 installed as your python library 
and the psycopg2 adapter.  There is no psycopg 2.0.11.

I am assuming this is still how psycopg is installed, the library and the DA 



On Tuesday 23 June 2009 16:06:03 Amir wrote:
> Hi,
>    I have (Zope 2.9.4-final, python 2.4.3, linux2) and I have used
> psycopg2.0.11 adapter to connect Zope to Postgresql but I am getting this
> error when I try to add the connection object the error is :-
> Error Type: ImportError
> Error Value: psycopg version mismatch (imported 2.0.11 (dt dec ext pq3))
> while the event log traceback shows that :-
> 2009-06-23T10:55:49 ERROR Shared.DC.ZRDB.Connection Error connecting to
> relational database.
> Traceback (most recent call last):
>   File "/opt/Plone-2.5/lib/python/Shared/DC/ZRDB/Connection.py", line 71,
> in __setstate__
>     try: self.connect(self.connection_string)
>   File "/opt/Plone-2.5/zeocluster/client1/Products/ZPsycopgDA/DA.py", line
> 120, in connect
>     raise ImportError("psycopg version mismatch (imported %s)" %
> ImportError: psycopg version mismatch (imported 2.0.11 (dt dec ext pq3))
> I would appreciate for an answer asap.
> Thanks
> Amir
> tlc2
> ***
> *

 Normally I'm against big things, 
 I think the world is going to be saved by millions of small things. 
Too many things can go wrong when they get big.
- Pete Seeger  at his 90th birthday party Sunday May 3, 2009

Thomas McMillan Grant Bennett           Appalachian State University
Operations & Systems Analyst            P O Box 32026
University Library                                Boone, North Carolina 28608
(828) 262 6587

Library Systems Help Desk: https://www.library.appstate.edu/help/

More information about the Zope mailing list