[Zope] Problem Building 2.10.x

Susan Day suzieprogrammer at gmail.com
Wed Mar 24 09:58:43 EDT 2010

On Wed, Mar 24, 2010 at 9:12 AM, Tres Seaver <tseaver at palladion.com> wrote:

> You should be able to override the "allowed" versions of Python:
>  $ cd /path/to/Zope-2.10.11
>  $ ./configure --with-python=/usr/bin/python && make inplace

I tried just that and got the following error:

error: command 'gcc' failed with exit status 1
make: *** [build] Error 1

So I did this:

[root at Zope-2.10.9-final]# yum install gcc

and got this at the end:


Dependency Updated:
  cpp.x86_64 0:4.1.2-46.el5_4.2          gcc-c++.x86_64
0:4.1.2-46.el5_4.2        libgcc.i386 0:4.1.2-46.el5_4.2
libgcc.x86_64 0:4.1.2-46.el5_4.2
  libstdc++.i386 0:4.1.2-46.el5_4.2      libstdc++.x86_64
0:4.1.2-46.el5_4.2      libstdc++-devel.x86_64 0:4.1.2-46.el5_4.2


So I tried Zope again and again got this:

error: command 'gcc' failed with exit status 1
make: *** [build] Error 1
[root at Zope-2.10.9-final]# gcc -V
gcc: '-V' option must have argument
# Whatever. At least it recognized gcc

So what up? I also tried installing Python 2.4.6 on my Mac and got a gcc
error!? What do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope/attachments/20100324/b525bd82/attachment.html 

More information about the Zope mailing list