[zope2-tracker] [Bug 142148] Re: DateTime default timezone wrong in some locations

Chris Hamono 142148 at bugs.launchpad.net
Wed Nov 10 00:34:15 EST 2010

Sorry but I am not particularly knowledgeable about zope/plone or even
python. I cannot find bin/instance? Perhaps it is created in the
buildout process.

We don't use buildouts, not my call that's just the way it is.
so I cant use... 
recipe = plone.recipe.zope2instance
environment-vars =
    TZ AEST-10AEDT-11,M10.1.0/02:00:00,M4.1.0/03:00:00

I tried setting the TZ in zope.conf but it did not take. I assume that
is because of the environment not being passed to the child environment
as mentioned in other posts about this bug.

When I tried to use TZ I used zopectl fg it didnt work. I think zopectl
is the actual script you are talking about. I can't see any
documentation mentioning other ways to start Zope. and as stated I used
zopectl and got no joy when setting the TZ variable.

The patch I submitted makes it work for Australian and presumably other
users. The fact that the timezone was hardcoded into DateTime only shows
the bug is more insidious than a simple 'typo'.

Why was it hardcoded into DateTime? perhaps because older servers had
the timezone configured to CST instead of US/Central!

Isn't it better that they configure their servers to the correct
timezone instead of using an old non portable syntax?

I stick by the fix, cst:US/Central in DateTime appears to be a kludge it
is non conformant with other entries in there.

Needless to say it works for us and it may also be the impetus for the
maintainers to actually fix the issue, which has remained open for 8
years. It certainly points towards where the real culprit lies.

Your fix may work well for you, but for us it did not work, probably
because we don't do it the "correct way".

I only bothered posting the fix here for those miserable few like us
that can't use other fixes.


DateTime default timezone wrong in some locations
You received this bug notification because you are a member of Zope 2
Developers, which is the registrant for DateTime.

More information about the zope2-tracker mailing list