[Zope3-dev] Plans for z3.py

Itamar Shtull-Trauring twisted@itamarst.org
Wed, 13 Feb 2002 11:49:12 +0000


You might want to use a specific naming convention:

Class ServerControl:
    def command_start(self):
      # xxx
    def command_stop(self):
      # xxx

i.e. commands are any method that begins with "command_". This makes 
adding utility methods much easier, since you can differentiate between 
published and non-published methods.