[Zope3-Users] Zope 3.1.0 make error -- permissions

cmire gnuguy at thelink.net
Thu Dec 8 21:23:05 EST 2005

I'm just not sure what to change under that directory.  I built Python 2.4.2 
as root, so I don't understand why I'm getting a permissions error on python 
when I try to build Zope 3.1.0 as root.  I've tried different su variations; 
I've tried just opening a raw root console.

I'm concerned about changing everything to 777 under Python-2.4.2 from a 
security standpoint.  I'm trying to build a website based on Zope and I don't 
want just anybody to be able to arbitrarily execute python code.

I reran make with "-d" to give me more details, and my guess is that Zope is 
being built using my python install, and python is trying to write the build 
file to the Zope-3.1.0 directory and can't.  If this is the case -- how do I 
fix it?  /usr/local/src is owned by root, as is /usr/local/src/Python-2.4.2 
and /usr/local/src/Zope-3.1.0.  Permissions are 755 all around, at the 
directory level and under.

Here is the tail end of the make -d output:

 No implicit rule found for `default'.
  Considering target file `build'.
   File `build' does not exist.
   Finished prerequisites of target file `build'.
  Must remake target `build'.
/usr/local/src/Python-2.4.2 install.py -q build
make: execvp: /usr/local/src/Python-2.4.2: Permission denied
Got a SIGCHLD; 1 unreaped children.
Putting child 0x08078210 (build) PID 6872 on the chain.
Live child 0x08078210 (build) PID 6872
Reaping losing child 0x08078210 PID 6872
make: *** [build] Error 127
Removing child 0x08078210 PID 6872 from chain.
linux:/usr/local/src/Zope-3.1.0 #

On Thursday 08 December 2005 12:12 am, Andreas Jung wrote:
> --On 7. Dezember 2005 20:45:11 +0000 gnuguy at thelink.net wrote:
> > I tried that in the zope-3.1.0 directory.  I changed everything to
> > 777 permissions.  No go.
> Maybe you need to read error messages carefully. There error occurs
> *HERE*: /usr/local/src/Python-2.4.2
> -aj

More information about the Zope3-users mailing list