[Zope3-Users] Renaming folder causes NotFoundError

John Smith jsmith030416 at yahoo.co.uk
Mon Nov 14 16:00:04 EST 2005

At the highest level of my content pages (ie the blue
pages in the zmi) i had a folder called 'myfolder'.

This folder contained my test objects ( the Car and
Journey example from my previous post). The data was
trivial and no loss to anyone. I'm still

Anyhow, I tried to rename the folder to something more
descriptive, and Zope3 keeps coming up with the "There
has been a system error" page, and on the terminal it
say s NotFoundError, 'myfolder'.

I have gone into the ZODB directly, and the
root['Application'] item contains the folder and its
contents, but with the new name 'MileageTracker'.

Firstly, I was a bit surprised that ZopeX3-3.0.0 did
this on a simple rename, although possibly it has
something to do with the contents of 'myfolder' which
where my own attempts at creating containers.

But now I'm intrigued because somewhere inside my ZODB
the system has remembered the old folder name even the
 root['Application'] mapping object only seems to know
the object by its new name.

I have tried renaming the object back to its original
name, and committing the transaction, but that does
not work, an incremented integer seems to be added to
the name.

As I said, I'm not bothered about the data itself, it
is just that I would like to use Zope3 in a production
environment and I'd like to know how to recover from
this type of thing.

I've tried debugging the source by putting in print
statements and as best I can tell, the magic is
somewhere around line 604 in
zope.app.registration.registration.py where "Adapters"
is the supplied name and a serviceregistration object
is createed whose componentPath attributes is
'myfolder'. From where in the ZODB is it reading this

Any help gratefully received,


Yahoo! Model Search 2005 - Find the next catwalk superstars - http://uk.news.yahoo.com/hot/model-search/

More information about the Zope3-users mailing list