[Zope3-Users] zope.app.cache.annotationcacheable question

Marcin Kołoczek mkoloczek at coig.katowice.pl
Fri Jan 5 07:43:49 EST 2007

Hi! I have question about AnnotationCacheable from module as in subject. 
Why getCacheId and setCacheId methods gets annotations in different way? 
I'm talking about:
annotations = IAnnotations(self._context)
annotations = IAnnotations(removeAllProxies(self._context))

The question araised when I tried to checked (in ZMI) programatically 
adding SQLScript into/by my own product and manually assigning it 
RAMCache named utility. But I coudn't set (existing and properly 
registered) cache via ZMI (at least 'Caching' view said that). Beside 
that RAMCache's statistics seems to told me, that everything is OK, 
indeed my product worked as expected :) After a few tries I added in 
ZMI's root folder a new SQLScript via ZMI (the standard Zope2's way) and 
got the same issue as with my product. On another computer i observed 
the same problem with 'Caching' view. After small invastigation I 
stucked with earlier mentioned methods' implementation differences. When 
I changed getCacheId to the same manner as setCacheId (add: 
removeAllProxies(self._context)) everything seems to work fine in 
'Caching' view...

Thanks for any replies


More information about the Zope3-users mailing list