[Zope3-Users] Still stuck without views.

Greg Baker gbaker at cs.mun.ca
Mon May 7 12:02:39 EDT 2007

On May 7, 2007 01:07:52 pm Robert Norman wrote:
> Hi again,
> I'm trying to learn Zope through the Web Component Development book and
> find myself stuck implementing simple views. This was posted earlier but
> and I've worked on it since but feel totally unable to proceed.
> I'm working on WinXP.  I can manipulate simple persistant objects using
> debugzope. The objects are listed in the ZMI. However I can't do anything
> with the views supplied as part of the example code.  For example, under
> debugzope , following the instructions in the text, if I try to examine the
> supplied view with:
> view = getMultiAdapter((lasagne, request), name=u'index.html')
> I get a lookup error.  Both lasagne, and request are valid objects.  Also,
> from my browser even though the ZMI shows my objects,  any attempt to view
> them fails. Apparently my view is not being registered. A line does exists
> in the configuration file that points to the folder containing the view...
> <include package=".browser" />
> This is all code supplied by the book pasted in from the web site -- I
> don't have the depth of knowledge of Zope yet to figure this out.
> I've tried re-installing Zope. I did a clean install of Zope with a new
> instance on a different machine (also WinXP) and get the same result.
> The browser folder contains a configuration file pointing to the supplied
> view with name="index.html".
> Where do I go from here?  I'd like to know what's wrong, but more
> importantly, I'd like to know how to go about finding out what's wrong
> without having to resort to this list.
> Thanks in advance...
> Robert

Does the zope server spit out any errors when you try to view these objects 
from a browser?  If so, paste them here, they may help.


More information about the Zope3-users mailing list