[Zope3-Users] ZwikiForZope3 start problems

George Wright georgewr at bigpond.net.au
Sat Dec 13 20:47:40 EST 2008

Following guides for setting up the Zwiki For Zope3 here: http://wiki.zope.org/zope3/ZwikiForZope3
I have had some problems.

It seems to have installed OK with this procedure:
svn co svn://svn.zope.org/repos/main/zwiki/trunk zwiki
cd zwiki
python2.4 bootstrap.py
./instance fg

  EXCEPT for the last step - which I presume is a typo - should be ./ 
bin/instance fg ?
Anyhow I get  an error message beginning:
/Users/georgewr/zwiki/parts/zwikiapp/runzope -C /Users/georgewr/zwiki/ 
Traceback (most recent call last):
   File "/Users/georgewr/zwiki/parts/zwikiapp/runzope", line 110, in ?
   File "/Users/georgewr/.buildout/eggs/zope.app.twisted-3.4.1- 
py2.4.egg/zope/app/twisted/main.py", line 74, in main
     service = setup(load_options(args))

<snip> # Some skipped but I can send it on if it helps ..........
and ending:
File "/Users/georgewr/.buildout/eggs/zope.configuration-3.4.1- 
py2.4.egg/zope/configuration/fields.py", line 141, in fromUnicode
     raise schema.ValidationError(v)
zope.configuration.xmlconfig.ZopeXMLConfigurationError: File "/Users/ 
georgewr/zwiki/parts/zwikiapp/site.zcml", line 15.0-15.27
     ZopeXMLConfigurationError: File "/Users/georgewr/zwiki/src/zwiki/ 
configure.zcml", line 285.2-285.32
     ZopeXMLConfigurationError: File "/Users/georgewr/zwiki/src/zwiki/ 
browser/configure.zcml", line 6.2-6.29
     ZopeXMLConfigurationError: File "/Users/georgewr/zwiki/src/zwiki/ 
browser/skin/configure.zcml", line 20.0-21.51
     ConfigurationError: ('Invalid value for', 'layer', "ImportError:  
Couldn't import wiki, No module named wiki")

Now there is a module called 'wiki.py'  in zwiki/src/zwiki/wiki.py

There is this comment "BBB 2006/02/18, to be removed after 12 months"  
appearing in both the browser/skin/__init__ and the browser/skin/ 
configure.zcml files. I wonder if that has anything to do with it?
By the way. If I run ./bin/test
I get the same error + "Total: 48 tests, 0 failures, 1 errors in 1.820  

George Wright
georgewr at bigpond.net.au

More information about the Zope3-users mailing list