[Zope3-Users] unregister, delete and pack, still no gc?

Adam GROSZER agroszer at gmail.com
Tue Dec 23 09:36:11 EST 2008

Hey Roy,

Can happen that BTrees keep deleted objects referenced, so they're not

See https://bugs.launchpad.net/bugs/294788

Tuesday, December 23, 2008, 8:35:22 AM, you wrote:

RM> Hi Folks,

RM> I have either stumbled on a storage leak in the ZODB, or I am
RM> missing something in my understanding of registration.

RM> Briefly, if I add a folder to the ZODB, make it a site, then
RM> unregister it, delete it and pack the ZODB, I see the ZODB
RM> increase in size.Each time I run the tests, the ZODB keeps growing
RM> (by about 7KB). I restarted the ZODB to see if it would help, but no!

RM> Here are my exact steps:

RM> 1. add a Folder
RM> 2. make a the folder a site.
RM> 3. register the folder (unnamed utility of type ISite)
RM> 4. remove the registration from the "registrations" tab.
RM> 5. delete the folder.
RM> 6. pack the ZODB.

RM> I have also attached a selenium test that performs all of this.

Best regards,
 Adam GROSZER                            mailto:agroszer at gmail.com
Quote of the day:
"I must do something" will always solve more problems than "Something must be done." 
- Unknown 

More information about the Zope3-users mailing list