[Zope3-Users] zope.sqlalchemy problems

Andre Schubert andre at km3.de
Wed Sep 10 10:30:43 EDT 2008


iam working on an large project since several years implemented with Zope2.
Now its time to make a big rework of our project, and thats the right time to switch it to Z3.
Because our data are stored in an PostgresDB i tried to play a little bit with Z3 and Postgres.
While searching through the archives i think Z3 + SQLAlchemy + zope.sqlalchemy is a rebust solution.

Because the data are represented as a tree-structure i tried to reimplement
a zope.app.folder.Folder, that the contained objects are fetched from Postgres via zope.sqlalchemy.

The good point here ist, that i could traverse to the object in the Postgres-DB via
I could see the ZMI and modify the data inside the Postgres-DB.

The only problem is with my Folder implementation.
If i try to access it directly via
i get the following error:

Traceback (most recent call last):
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.publisher-3.5.3-py2.4.egg/zope/publisher/publish.py", line 133, in publish
    result = publication.callObject(request, obj)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publication-3.4.3-py2.4.egg/zope/app/publication/zopepublication.py", line 167, in callObject
    return mapply(ob, request.getPositionalArguments(), request)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.publisher-3.5.3-py2.4.egg/zope/publisher/publish.py", line 108, in mapply
    return debug_call(obj, args)
   - __traceback_info__: <security proxied zope.app.publisher.browser.viewmeta.ManagementViewSelector instance at 0xaca466c>
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.publisher-3.5.3-py2.4.egg/zope/publisher/publish.py", line 114, in debug_call
    return obj(*args)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publisher-3.5.0-py2.4.egg/zope/app/publisher/browser/managementviewselector.py", line 35, in __call__
    item = getFirstMenuItem('zmi_views', self.context, self.request)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publisher-3.5.0-py2.4.egg/zope/app/publisher/browser/menu.py", line 195, in getFirstMenuItem
    items = getMenu(id, object, request)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publisher-3.5.0-py2.4.egg/zope/app/publisher/browser/menu.py", line 190, in getMenu
    return menu.getMenuItems(object, request)
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publisher-3.5.0-py2.4.egg/zope/app/publisher/browser/menu.py", line 55, in getMenuItems
    if item.available():
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.app.publisher-3.5.0-py2.4.egg/zope/app/publisher/browser/menu.py", line 134, in available
    if not canAccess(view, '__call__'):
  File "/root/virtualzope1/cmms1/buildout-eggs/zope.security-3.5.2-py2.4-linux-i686.egg/zope/security/checker.py", line 134, in canAccess
    checker.check_getattr(obj, name)
ForbiddenAttribute: ('__call__', <satest1.user.User object at 0xb47322c>)

I hope someone could help me a little bit.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.zope.org/pipermail/zope3-users/attachments/20080910/30549592/attachment.bin 

More information about the Zope3-users mailing list