[Grok-dev] Re: grok version conflict

Wichert Akkerman wichert at wiggy.net
Mon Aug 20 11:10:57 EDT 2007

Previously Martijn Faassen wrote:
> Wichert Akkerman wrote:
> >Buildout tells me this:
> >
> >Error: There is a version conflict.                                        
> >We already have: zope.app.keyreference 3.5.0b1                             
> >but grok 0.9dev-r78980 requires 'zope.app.keyreference==3.4.0a1'.          
> >
> >which means you can not create a grok buildout at the moment.
> Interesting. This is with the recent SVN version? I changed some version 
> requirements recently but didn't run into this running my buildout.
> I just tried a fresh checkout and a buildout -n, but grok installs 
> correctly.
> Could you tell me the exact steps you do in order to reproduce this problem?

I blew away my buildout cache and it works now. Philipp suggested that I
may have been bitten by the "newest = False" in buildout.cfg. That be
true - I keep forgetting that setting is there.


Wichert Akkerman <wichert at wiggy.net>    It is simple to make things.
http://www.wiggy.net/                   It is hard to make things simple.

More information about the Grok-dev mailing list