[Grok-dev] Help installing grok2html

Luciano Ramalho luciano at ramalho.org
Wed Jul 18 15:33:31 EDT 2007

I need to run grok2html to generate the tutorial.html from the files
we produced during the Brazilian sprint. During the spring one
participant (Daniel) managed after several hours to make the script
run in his machine, but it required some hand-editing of files. Since
then all my attempts to setup the grok/doc/ system have failed, and I
tried several machines and distributions, even with Daniel's help.

In order to document the issue I've setup a clean Ubuntu 7.04 in a
VMware VM, installed the python2.4 and python2.4-dev packages, then
setup Grok per instructions in the tutorial and everything worked fine
so far.

Then I did a checkout of grok from svn, and executed the commands
below. The problem is dependency on zope.app which I believe is an
error, but I don't know how to fix.

Also, it's worth pointing out that running the doc/setup.py downloads
all over the packages that grokproject had already pulled... I could
try to fix this but I'd need some hand-holding to do it as I am still
quite ignorant regarding the new setup infrastructure.



luciano at ub704:~/grok/doc$ sudo python2.4 setup.py build
[... snip half dozen lines of output ...]
luciano at ub704:~/grok/doc$ sudo python2.4 setup.py install
[...snip 1000's of lines...]

Searching for zope.app
Reading http://cheeseshop.python.org/pypi/zope.app/
Couldn't find index page for 'zope.app' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://cheeseshop.python.org/pypi/
No local packages or download links found for zope.app
error: Could not find suitable distribution for Requirement.parse('zope.app')

luciano at ub704:~/grok/doc$ grok2html ~/www/
Traceback (most recent call last):
  File "/usr/bin/grok2html", line 5, in ?
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py",
line 2561, in ?
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py",
line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py",
line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: zope.app
luciano at ub704:~/grok/doc$

More information about the Grok-dev mailing list