[Grok-dev] naming conventions
faassen at startifact.com
Fri Mar 16 11:06:04 EDT 2007
Philipp and I had some discussion about naming conventions as a result
of the applyChanges versus apply_changes debate. We've decided to go
back to the Zope 3 conventions for method names. I've checked in a file
in doc/naming_conventions.txt which describes our naming conventions.
For class annotations (grok.local_utility) we break with Zope 3
tradition and use underscores.
The only decision still deferred is what naming convention to use for
top level functions in modules (that are not defining class
annotations). Zope uses camelCase (getUtility). Grok internally now uses
under_scores, but we don't expose those yet to the outside world. What
to do here? Perhaps we'll defer the discussion until we actually have
some non-class annotation top-level functions to expose.
More information about the Grok-dev