[Grok-dev] "baseclass" or "ignore"?

Fernando Correa Neto fcdoth at gmail.com
Thu Oct 25 12:17:58 EDT 2007


On 10/25/07, Brandon Craig Rhodes <brandon at rhodesmill.org> wrote:
> While reading template code, it occurred to me that:
>     class MyClass(...):
>         grok.ignore()
> is more readable than:
>     class MyClass(...):
>         grok.baseclass()

+1 for grok.ignore(). I can't see any other naming to tell martian not
to grok this. Maybe grok.dontgrok() but I think grok.ignore() is ok.


More information about the Grok-dev mailing list