[Grok-dev] Re: on the name "Grok"
faassen at startifact.com
Mon Apr 28 09:32:48 EDT 2008
Wichert Akkerman wrote:
> Previously Martijn Faassen wrote:
>> There is also 'plone.grok'. This provides plone-specific components and
>> grokkers, dealing with Plone specific concepts such as portlets. In
>> order to use it, you import from it. I think this name is very *wrong*.
>> It leads people to believe that these base classes exist in Grok, which
>> they do not. It's not implementing standard Grok concepts at all, but
>> extends Grok. It therefore the namespace shouldn't have 'grok' in it.
>> Ideally it's just something that is folded into existing Plone packages.
> megrok.plone ?
Yeah, 'megrok' is for grok extensions, so that could work. I suspect
though that grokkers could just be folded into the appropriate libraries
More information about the Grok-dev