[Zope-DB] Issues of MySQLdb and ZMySQLDA

Martin Gebert Murphy@members.netsolution-net.de
Thu, 19 Dec 2002 12:26:55 +0100

Dieter Maurer schrieb:

>Martin Gebert writes:
> > First, I ran into problems when I tried to do
> > 
> > from MySQLdb import *
> > 
> > in Python 2.1.3 (console) due to missing attributes in that package 
> > (some date and time attributes or functions). Deleting the referring 
> > declarations from the __init__.py/__all__ list seemed to work...
>Looks fine.
So I suppose you validated that. Thanks!

>Send him the patch.
I already tried some months ago. No response till now :-(
Perhaps I get kicked by his spam filter?

>Maybe place it in your member area on "Zope.org", too, such that others
>can use it.
I'll do that.

> > whenever there's a MaxRows attribute set. If I set the MaxRows to 0 it 
> > works flawlessly.
> > My best guess would be that there's a problem with the order of the 
> > locking statements and the LIMIT parameter; the latter is simply 
> > appended to the SQL statement where it should appear before the locks.
>I am sure you are right.
OK; maybe I'll have a closer look at the code myself the next days. But 
I promise nothing ;-)

Have a relaxing time.