[Zope-DB] win32 odbc DA constantly losing connection

Charlie Clark charlie@begeistert.org
Wed, 26 Feb 2003 14:56:24 +0100

On 2003-02-26 at 09:10:38 [+0100], T. Muddletin wrote:
> In desperation searching for alternatives i finally got slightly old 
> psycopg working using the binary found on zope.org at 
> http://www.zope.org/Members/pvl/PsycopgWin32 and I was a (relatively) 
> happy camper again... things seemed grand.
> And then suddenly this DA lost its connection also. Distressing! However, 
> there was a difference... when i tried to re-open this connection i see 
> the error: "psycopg.OperationalError FATAL: Sorry, too many clients 
> already"
> AH!! So that's it! Now at least I know what seems to be the actual 
> problem. I'm still not happy about the DA completely shutting down... 
> what's it doing with all those other connections it is holding open? But 
> at least now I can try to work with the problem and increase the 
> connections available in postgresql or something.

I'm working with that psycopg DA on windows and find it fine apart from the 
hideous memory leak when doing mass inserts with NULLS. However, it is 
difficult getting an uptodate Windows binary. I hope to have a go at this 
at some point assuming it is at all possible with a Borland compiler. Of 
course, postgreSQL on cygwin isn't really ideal and I'd like to move to BSD 
completely myself when I can get one of my three versions to work properly:
4.6 won't give me X-Windows (mysteriously missing ATI drivers);
4.7 seems to have trouble with the CD-ROM making boots about 5 minutes long;
5.0 chokes on the PCCARD manager

oh the fun and joys of UNIX. If only select() worked on BeOS I'd be such a 
happy bunny.

mxODBC is rock solid, I know 'cos I've got it in a production site 
somewhere. What I don't understand is how you're getting the same error 
with an ODBC and a native driver.