[Zope-DB] Zope 2.7.0 and MySQL: What Am I Missing?

Roy S. Rapoport zope-db at ols.inorganic.org
Tue Jun 8 03:15:11 EDT 2004

When last I had Zope functional, it was 2.6.1 with Python 2.1.3, and
ZMySQLDA worked flawlessly.

Now I'm trying to get Zope 2.7.0 with Python 2.3.3 and MySQL (4.1.12)
working, and ... it's just not.

I originally tried MySQL-Python 0.9.3b1 and ZMySQLDA 2.0.8; My latest
attempt has been with MySQL-Python 1.1.1 and ZMySQLDA 2.0.9b2.  I've also
patched db.py as per Chris Withers' suggestion and tried to do a mailing
list search (where I came across Chris's discussion).

It feels like I'm missing some magical combination of versions that will
set me right, but I can't figure out what that combination is.

My symptoms are that when I include this product, Zope runs for a moment,
but as soon as I try a request, any request, it terminates the connection
and then does not respond to connection attempts.  No information is logged
in Z2.log.

What am I missing?


More information about the Zope-DB mailing list