[Zope-DB] Re: Database Corruption (1 possible solution)

Nick Bower nicholas.bower at jrc.it
Wed Jun 30 06:25:35 EDT 2004

I was going to post this tip on it's own, but seeing how it's relevant 
to the current discussion, I'll post it here.

Recently we've been having "read conflict errors" preventing Zope from 
connecting to a ZODB on startup in a ZEO deployment.  (Moving the 
Data.fs* to a standalone non-ZEO configuration made no difference).

Upon a little digging, I found an error relating to an illegal attempted 
reassignment of an oid.

I tried the recovery tools, but these did nothing.

The solution was to remove the Data.fs.index and Data.fs.tmp files and 
let ZODB rebuild them on startup.  Why this worked I have no idea (it 
was a stab in the dark at the time) as I don't know much about ZODB 
internals.  However, this happened to us twice in a single week (which 
on it's own is quite sad).

Ramon Aseniero wrote:
> Hi All,
> Is there a way to prevent the Zope database from being corrupted?
> Thanks,
> Ramon
> ------------------------------------------------------------------------
> _______________________________________________
> Zope-DB mailing list
> Zope-DB at zope.org
> http://mail.zope.org/mailman/listinfo/zope-db

More information about the Zope-DB mailing list