[ZWeb] QueuedCatalog not being processed...

Chris Withers chris at simplistix.co.uk
Fri Jul 2 02:58:39 EDT 2004

Hi All,

Trying to publish some objects people had submitted, I kept on getting a 
"WorkflowError". Chatting with Michael Bernstein, he suggested that the 
QueuedCatalog was backing up and had 19 unprocessed items in it.

Apparently a cron job wasn't running that was supposed to be running but 
apparently it was being fixed.

So anyway, those items went through.

I came back today and tried to publish another object, same thing. With my shiny 
new manager access I hada look at the QueuedCatalog: 19 items in queue again.
I pushed the process queue button, they alla vanished.

My publish didn't error when I re-tried it, but the pending view still said one 
object was pending.

Off I went to the QueuedCatalog: 1 object in queue. I pushed the button, it went 

What's going on here?

This didn't need to be done a week ago. What's changed?


Simplistix - Content Management, Zope & Python Consulting
            - http://www.simplistix.co.uk

More information about the Zope-web mailing list