[Zope] strange zope behavoir: zope not responding

Jean-Francois.Doyon at CCRS.NRCan.gc.ca Jean-Francois.Doyon at CCRS.NRCan.gc.ca
Fri Oct 31 16:51:34 EST 2003

To case #2, I have experienced this.  Zope just stops responding.  It's not
using any more resources than usual or anything, just stops responding.

The issue with the processes, I think, is that possibly the master process
or thread restarts itself, but the PID file doesn't get overwritten.  So you
now have a Zope running with a different PID than what is in the file. As
such, running the "stop" script doesn't help. You have to issue a SIGKILL in
order to shut it down (When I experience these symptoms, I've tried other
signals without success).

I am running 2.6.1 with Python 2.1.3.

So far as I can tell server load is perfectly normal when this occurs, and
it doesn't seem related to uptime.this week it happened twice in one day,
but hadn't happened for a couple of weeks before that.

In my case though I'm using Apache as a proxy, and Apache seems to lock up
as well: it no longer spawns children for new requests.

I've also seen it happen where apache's slots all fill up and then
everything stops responding.

In my case, I'm suspecting a nasty Coldfusion MX setup on the same box that
I think has a race condition that takes up 100% CPU every once in a while.
Had to track down though. But a race condition on a process would definitely
show the types of symptoms describe here.

Either way, I'd still like to hear comments/ides/solutions on this issue,
just in case I'm following the wrong lead!


-----Original Message-----
From: zope-bounces at zope.org [mailto:zope-bounces at zope.org]On Behalf Of
Matthew Thorley
Sent: Friday, October 31, 2003 9:34 AM
To: zope at zope.org
Subject: [Zope] strange zope behavoir: zope not responding

I have observed some strange behavior from two of my zope servers (ver
that I am unable to find a cause for. FYI both servers are running on intel 
boxes under redhat 9.0.

Case one;
When I start the server in debug mode everything appears to be fine. When I 
went to the servers url on port 8080 I see the default indexpage. When I 
click the link for the management section I get a dialog to log in. After 
entering the correct user and pass my browser attempts to load the
section and hangs. Generall it builds the frames for the page and loads the 
data for the header frame and the text for the left (navigational frame) but

only empty (image-not-loaded-yet-icon) boxes where the images should be and
can see nothing in the main page frame.

If I restart the server the same thing happens. I also tried starting the 
server with these options -a ipaddress -Z1 -t 10 -f - -w - . 

After the page hangs it won't load(server?) the index page any more or any 
other page. My browser just sits there doing nothing until it times out with

'document contained not data'

Case two 
After I start my server (different server then case 1) everything is fine
dandy for some time. I can create object, test objects and do normal zope 
stuff. At some point thought the server hangs, meaning any page I visit 
refuses to load and eventualy times out. At this point I can't even reload 
the page for objects that I am currently working on. The only thing that I 
remedies this is to restart zope.

Another thing that I have observed is that generaly speaking when the server

gets to this stage, if I press ctrl+c to kill the server (in the window
it shows that it is running) It doesn't actualy kill the server. I don't get

the messages:

2003-10-31T00:50:45 INFO(0) Z2 Closing all open ZODB databases
2003-10-31T00:50:45 INFO(0) Z2 Shutting down

It just dies silently.  But if I run ps aux | grep Zope it shows a Zope 
process running.

Does any one have any idea why this is happening ? or have you ever 
experienced this yourself?

thanks very much

Zope maillist  -  Zope at zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

More information about the Zope mailing list